Forum Replies Created

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • in reply to: Plus alias support test message never sends #27991
    Jennifer Sabree
    Participant

    Thanks for the clarification about which plugin sends emails.

    I’m getting the staging site set up now. Will email you the login and credentials.

    in reply to: Plus alias support test message never sends #27985
    Jennifer Sabree
    Participant

    The log is empty, as is Pantheon’s PHP error log. It’s like the site simply refuses to send email via RBE. I’m starting to suspect it’s a Pantheon thing. Tomorrow I can contact Pantheon support and see if they can help.

    I checked out Pantheon’s support docs. Found this known issue with confirmation emails sent by the SendGrid Subscription Widget, which might be relevant.

    I did some testing and troubleshooting yesterday and have a long list of what isn’t the problem.

    First, here’s what your debugging/testing tool has continued to report.

    Testing Connectivity… OK
    Testing “plus alias” support: Sending test message… OK
    Testing “plus alias” support: Checking arrival (pass 3 of 3)… Failed Test message not found in mailbox.
    We could not find the test message we sent to your inbox. Please use Gmail/Hotmail/Outlook or ask your email provider if they support “plus aliases”.

    But we know plus aliases on Rackspace work. Test messages are sitting unread in my Rackspace mailbox.

    When I run the webhook I get “No new messages to process”.

    Creating a new topic via email works consistently.

    I updated bbPress to the latest version yesterday.

    This site has Paid Memberships Pro and several related plugins installed, including the PMPro bbPress Add On. It individual forums to be locked down for members, which was the case initially.

    Test cases, all resulting in no change
    1. Remove all membership restrictions
    2. Disable Paid Memberships Pro – bbPress Add On
    3. Disable Code Snippets (used for customization of PMPro and a few other plugins)

    PMPro has this under email settings. I’d left “Only Filter PMPro Emails?” unchecked initially. I checked it and tested. No change, so it’s back to being unchecked.

    Send Emails From
    By default, system generated emails are sent from wordpress@yourdomain.com. You can update this from address using the fields below.

    From Email: aaapeds@nwcty.com
    Only Filter PMPro Emails?: [checkbox] If unchecked, all emails from “WordPress <wordpress@appserver-084ba167-nginx-a8285bb823ff49b7bdc7c23e7daf65c8>” will be filtered to use the above settings.

    That’s all I got.

    in reply to: Plus alias support test message never sends #27978
    Jennifer Sabree
    Participant

    I followed your directions exactly. After running the webhook I got “No new messages to process.” The test message is unread in my inbox.

    To be sure it’s not a caching issue I cleared Pantheon’s cache and ran the webhook in an incognito window.

    This site is plugin-heavy out of necessity. If you’re out of ideas, I can do more troubleshooting by disabling plugins.

    in reply to: Plus alias support test message never sends #27975
    Jennifer Sabree
    Participant

    It says “No new messages to process.”

    (Thank you again for your prompt replies!)

    in reply to: Plus alias support test message never sends #27973
    Jennifer Sabree
    Participant

    I do. That part is working.

    in reply to: Plus alias support test message never sends #27970
    Jennifer Sabree
    Participant

    I’m back.

    The plus alias support test is working. Although I’ve confirmed that Rackspace does allow plus aliases, the debugging tools shows this when I run the test now.

    Testing Connectivity… OK
    Testing “plus alias” support: Sending test message… OK
    Testing “plus alias” support: Checking arrival (pass 3 of 3)… Failed Test message not found in mailbox.

    Here are my settings.

    `Array
    (
    [provider] => custom
    [type] => imap
    [host] => secure.emailsrvr.com
    [port] => 993
    [ssl] => SSL
    [recipient] => ***REDACTED***
    [username] => ***REDACTED***
    [password] => ***REDACTED***
    [delete_read_messages] => 1
    [last_message_epoch] => 0
    [allow_images] =>
    [allowed_attachments] => Array
    (
    [0] => application/msword
    [1] => application/pdf
    [2] => image/bmp
    [3] => image/gif
    [4] => image/heic
    [5] => image/jpeg
    [6] => image/png
    [7] => image/tiff
    [8] => image/webp
    [9] => image/x-icon
    [10] => text/calendar
    [11] => text/css
    [12] => text/csv
    [13] => text/html
    [14] => text/plain
    [15] => text/richtext
    [16] => text/tab-separated-values
    [17] => text/vtt
    [18] => video/3gpp
    [19] => video/3gpp2
    [20] => video/avi
    [21] => video/divx
    [22] => video/mp4
    [23] => video/mpeg
    [24] => video/ogg
    [25] => video/quicktime
    [26] => video/webm
    [27] => video/x-flv
    [28] => video/x-matroska
    [29] => video/x-ms-asf
    [30] => video/x-ms-wm
    [31] => video/x-ms-wmv
    [32] => video/x-ms-wmx
    )

    [allow_html] =>
    [max_upload_size] => 100
    [max_upload_unit] => KB
    [max_upload_total_size] => 300
    [max_upload_total_unit] => KB
    [smtp_host] => secure.emailsrvr.com
    [smtp_port] => 465
    [smtp_ssl] => SSL
    [smtp_auth] => 1
    [smtp_username] => ***REDACTED***
    [smtp_password] => ***REDACTED***
    [check_method] => webhook
    [check_frequency] => 1
    [trigger_url_key] => ***REDACTED***
    [subscription_integration] => auto_subscribe
    [subscribe_to_topics] => 1
    [topics_by_email_enabled] => 1
    [title_max_length] => 80
    [oauth_access_token] => N/A
    [oauth_client_id] => ***REDACTED***
    [oauth_client_secret] => ***REDACTED***
    [reply_above_string] => If you want to reply, type it above this line
    [click_to_reply_text] => Click to reply
    [digests_integration_enabled] =>
    [is_complete] => 1
    [connection_test] => 1
    [server_port_accessible] => 1
    )`

    At this point I’m not sure if it’s a WordPress thing or a Pantheon thing. There are no new errors in the error log.

    The only other thing I can think to mention is that the bbPress Reply By Email setting “Delete Read Messages” is set to yes.

    • This reply was modified 2 months ago by vinny.
    in reply to: Plus alias support test message never sends #27969
    Jennifer Sabree
    Participant

    Worked like a charm. Thanks again!

    in reply to: Plus alias support test message never sends #27967
    Jennifer Sabree
    Participant

    Thank you for the quick turnaround!

    I sent an email as you suggested to test plus aliases. They are indeed supported by Rackspace.

    in reply to: Plus alias support test message never sends #27962
    Jennifer Sabree
    Participant

    Here’s a possible clue from the error log. We’re hosted on Pantheon.

    wp-includes/PHPMailer/PHPMailer.php:1925

    Uncaught Error: Class ‘PHPMailer\PHPMailer\SMTP’ not found in /code/wp-includes/PHPMailer/PHPMailer.php:1925
    Stack trace:
    #0 /code/wp-includes/PHPMailer/PHPMailer.php(2046): PHPMailer\PHPMailer\PHPMailer->getSMTPInstance()
    #1 /code/wp-includes/PHPMailer/PHPMailer.php(1962): PHPMailer\PHPMailer\PHPMailer->smtpConnect(Array)
    #2 /code/wp-includes/PHPMailer/PHPMailer.php(1640): PHPMailer\PHPMailer\PHPMailer->smtpSend(‘Date: Fri, 19 N…’, ‘This is a multi…’)
    #3 /code/wp-includes/PHPMailer/PHPMailer.php(1473): PHPMailer\PHPMailer\PHPMailer->postSend()
    #4 /code/wp-content/plugins/bbpnns-reply-by-email/includes/controller/ajax.class.php(175): PHPMailer\PHPMailer\PHPMailer->send()
    #5 /code/wp-includes/class-wp-hook.php(303): BbpnnsReplyByEmail_Controller_Ajax->send_plus_alias_test(Array)
    #6 /code/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(”, Array)
    #7 /code/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
    #8 /code/wp-admin/admin-ajax.php(187): do_action(‘wp_ajax_Bbpnns

Viewing 9 posts - 1 through 9 (of 9 total)