Shop Forums WordPress Plugins RBE doesn’t work anymore

Viewing 8 reply threads
  • Author
    Posts
    • #24208
      Torben Heikel
      Participant

      Hi

      I’ve set up RBE and it has worked fine until February/March I think, but it doesn’t work anymore. I use Version 1.13.2 and have set it up using Gmail and webhook triggered by https://cron-job.org/

      When I hit the Test Connection in settings I get a fine green OK.

      What could be wrong?

      Array
      (
      [provider] => gmail
      [type] => imap
      [host] => imap.gmail.com
      [port] => 993
      [ssl] => SSL
      [recipient] => ***REDACTED***
      [username] => ***REDACTED***
      [password] => ***REDACTED***
      [delete_read_messages] => 1
      [last_message_epoch] => 1580219094
      [allow_images] =>
      [allowed_attachments] => Array
      (
      [0] => image/gif
      [1] => image/jpeg
      [2] => image/png
      )

      [allow_html] => 1
      [max_upload_size] => 100
      [max_upload_unit] => KB
      [max_upload_total_size] => 300
      [max_upload_total_unit] => KB
      [smtp_host] =>
      [smtp_port] =>
      [smtp_ssl] => NO
      [smtp_auth] => 0
      [smtp_username] =>
      [smtp_password] =>
      [check_method] => webhook
      [check_frequency] => 1
      [trigger_url_key] => ***REDACTED***
      [subscription_integration] => bbpnns
      [subscribe_to_topics] => 1
      [topics_by_email_enabled] =>
      [is_complete] => 1
      [server_port_accessible] => 1
      [connection_test] => 1
      )

    • #24209
      vinny
      Keymaster

      Hi Torben,

      Google has been mucking up Less Secure Apps settings. Please make sure you still have Less Secure Apps enabled for that account. If you do, then you will need to create an application password (especially if you’re using 2FA).

      I’m working with Google to approve the project I’ll be using to release the oAuth version of RBE so that these things don’t happen in the future.

      Let me know if the steps above resolve the issue for you.

      Cheers,
      Vinny

    • #24222
      Torben Heikel
      Participant

      Hi Vinny

      Thank you for you quick answer. I checked my Google account and it has still Less Secure Apps enabled. I then created an application password and enabled 2FA (because I couldn’t create the application password without).

      After that the test connection still works, but nothing happens when my cronjob trickers the Webhook URL.

      What can I do to get it work? Do I have to wait for version 2.0 of your plugin in order to use the oAuth method?

      Cheers
      Torben

    • #25867
      vinny
      Keymaster

      Hi Torben,

      The issue doesn’t seem related to the connection, according to your latest message. Can you create a temporary admin account for me so I can run a few tests? Please use vinny [at] usestrict [dot] net.

      Cheers,
      Vinny

    • #25964
      Torben Heikel
      Participant
      This reply has been marked as private.
    • #25967
      vinny
      Keymaster

      Thanks, Torben.

      Please make sure I’m an admin as I don’t see a) bbpnns menu; b) Settings menu.

    • #25975
      Torben Heikel
      Participant
      This reply has been marked as private.
    • #25993
      vinny
      Keymaster

      Hi Torben,

      Sorry for the late reply. Please update the plugin to version 2.0.1 and connect via oAuth. That should bypass any issues from Google.

      Let me know how it goes.

      Cheers,
      Vinny

    • #25996
      Torben Heikel
      Participant

      Hi Vinny

      I updated the plugin to version 2.0.1 a week ago but it still doesn’t work for me 🙁 You’re very welcome to test again. I haven’t deleted your account.

Viewing 8 reply threads
  • You must be logged in to reply to this topic.