Shop Forums WordPress Plugins Notify by email version 1.2.3 stopped sending emails

Viewing 1 reply thread
  • Author
    Posts
    • #7033
      dongrillo
      Participant

      Upgraded Notify by Email to version 1.2.3 and it has stopped sending emails to subscribers. WP is sending out the email of the bbPress topic but they are not going to the gmail account. When I go to the webhook URL, the message is “Nothing to Process”. All connection settings test OK.

      Array
      (
      [provider] => gmail
      [type] => imap
      [host] => imap.gmail.com
      [port] => 993
      [ssl] => SSL
      [recipient] => ***REDACTED***
      [username] => ***REDACTED***
      [password] => ***REDACTED***
      [delete_read_messages] => 1
      [last_message_epoch] => 1523485698
      [allow_images] => 1
      [allow_html] => 1
      [max_upload_size] => 150
      [max_upload_unit] => KB
      [max_upload_total_size] => 2
      [max_upload_total_unit] => MB
      [smtp_host] => smtp.gmail.com
      [smtp_port] => 465
      [smtp_ssl] => SSL
      [smtp_auth] => 1
      [smtp_username] => ***REDACTED***
      [smtp_password] => ***REDACTED***
      [check_method] => webhook
      [check_frequency] => 1
      [trigger_url_key] => ***REDACTED***
      [is_complete] => 1
      [server_port_accessible] => 1
      [connection_test] => 1
      )

    • #7034
      vinny
      Keymaster

      Hi Don,

      Can you email me your log.txt file as well? Send it to vinny [at] usestrict [dot] net.

      Thanks!

      • #7036
        dongrillo
        Participant

        Resolved!!! Found the messages! Always check the SPAM folder for messages!!

        You may delete this topic.
        Don

        • #7052
          vinny
          Keymaster

          Hi Don,

          Sorry for the flurry of test replies. I was following my logs which indicated failure but not checking the forum.

          The false failure in the logs was being caused by bbPress’ Akismet extension, which force checks for Anonymous data even when it’s not anonymous (the case with RBE). I should probably open a ticket for them.

          As for Spam, I’ve noticed several forum notifications from different forums going to the spam folder. This is either because the domain’s SPF and DKIM are not configured properly, or because people are flagging the forum messages as Spam, instead of unsubscribing from the forums.

          In case you are using role-based notifications, I strongly advise that you get the Opt Out add-on to allow people to unsubscribe via a link in the messages instead of flagging them as spam.

          Cheers,
          Vinny

Viewing 1 reply thread
  • You must be logged in to reply to this topic.