Shop Forums WordPress Plugins No line breaks in topic content when Bulk Mailer add-on is enabled

Tagged: 

Viewing 7 reply threads
  • Author
    Posts
    • #27721
      Torben Heikel
      Participant

      Hi

      When I enable the Bulk Mailer add-on in BuddyBoss the output of [topic-content] is stripping all the line breaks, so the whole message is one big paragraph. If I disable Bulk Mailer again the email looks nice again.

      I use Mailgun as Mailer Service and have never had any problems before with them.

      Best wishes
      Torben

    • #27722
      vinny
      Keymaster

      Hi Torben,

      Thanks for reaching out. Can you try it with vanilla bbPress on a staging server and let me know if the issue also happens?

      Cheers,
      Vinny

      • #27725
        Torben Heikel
        Participant

        Hi Vinny

        Yes of course. I have now tried on a staging server with the following plugins:
        bbPress 2.6.6
        bbPress Notify (No-Spam) 2.17
        bbPress Notify (No-Spam) Bulk Mailer 1.6.5
        WP Mail SMTP 3.0.3

        And the Twenty Twenty-One theme.

        Unfortunately, the issue is the same (even though BuddyBoss only runs on a fork of bbPress 2.5.14-6684).

      • #27726
        Torben Heikel
        Participant
        This reply has been marked as private.
    • #27806
      Torben Heikel
      Participant

      Hi Vinny

      Did you have a look at my issue with the Bulk Mailer add-on?

      All the best
      Torben

    • #27811
      vinny
      Keymaster

      Hi Torben,

      Sorry for the delay. The fix has been released in version 1.6.6.

      Cheers,
      Vinny

    • #27869
      Torben Heikel
      Participant

      Hi again Vinny

      Thank you for the fix, but I just realise that it didn’t fix the issue when someone reply to an email. If the Bulk Mailer add-on is enabled it works fine for new topics where “[topic-content]” returns text with line breaks. But with replies “[reply-content]” output the text with no line breaks.

      It also seems that it takes much longer to send the replies than the topics. In BuddyBoss the send button keeps spinning when I hit a reply. With topics, it’s sending right away without spinning.

      I hope you can help again!

      /Torben

    • #27870
      vinny
      Keymaster

      Hi Torben,

      I can’t remember if I checked against “[reply-content]”, but it may as well have slipped through the cracks. As for the send button spinning, please enable background notifications. You probably have more people set to receive replies than topics, which is causing the posting process to hang until all emails have been sent out. With background notifications enabled, this will no longer happen.

      Cheers,
      Vinny

    • #27872
      Torben Heikel
      Participant

      Hi Vinny

      Thanks. It would be awesome if you could check and fix the [reply-content] issue!

      I’m not happy to enable background notifications because I need the notifications being send instantly when a topic or a reply has been written. And actually it’s the same people that gets the replies and topics so they should react with the same “spinning”

      • #27894
        vinny
        Keymaster

        If you create a real cron job to run every minute, then your users won’t have to wait more than that long to get their notifications. I recommend using wp-cli (if it’s available in your host) to run the job:

        /path/to/wp --path=/path/to/wordpress cron event run --due-now >/dev/null 2>&1

        Change the paths above to point to the right place and you’ll have excellent results.

    • #27893
      vinny
      Keymaster

      Hi Torben,

      I’ve released the fix in version 1.6.7. Please update.

      Cheers,
      Vinny

Viewing 7 reply threads
  • You must be logged in to reply to this topic.