Shop Forums WordPress Plugins Help : start to work, but stop when installing "bbPNNS Private Groups Bridge"

Viewing 5 reply threads
  • Author
    Posts
    • #4831
      Thierry
      Participant

      Hello winny,

      First, sorry for my bad english 🙁

      I’ve made a new site for a group of person : https://conexion.boissy.eu

      There are 2 categories of formum : 8 “public” forums (“Les Forums de la Copro Connexion”) and 5 else reserved for some people (“Les forums du Conseil Syndical”); group and role plugin are installed and permit me to limit access of the reserved forum but also, to the public forum that is in fact reserved to only register people.

      I wanted to propose a new function: send notification when a new topic and reply are made… For this, i’ve found your plugin “bbPress Notify (No-Spam)” : it has worked fine… until i’ve wanted to limit sending notification to only best group (i did not wanted to send a private topic from “Les forums du Conseil Syndical” to soneone that has not accès to this forum. So, i’ve found on your site “bbPNNS Private Groups Bridge” to use with “bbP private groups” plugin. I’ve installed both and it’s at this time i lost my head 🙁

      Actually, even when i only install “bbPress Notify (No-Spam)”, notfication is not sent ! whereas an other plugin (“BbPress Notification”) can send notifications to admin when i activate it !!!

      I’ve saw that when i uninstall all bbpress plugin (“bbPress Notify (No-Spam)” and “bbP private groups”), my preferences are still in memory – so, in base ! It’s not TOP and you’ll better include an option that will permit to delete all informations of your plugin when it will be deleted.

      What can i do ? i can let you access to my site (tell me what sort of user you want) if you want…

      Thank’s a lot for anwser,

      Thierry

    • #4833
      vinny
      Keymaster

      Hi Thierry,

      So, i’ve found on your site “bbPNNS Private Groups Bridge” to use with “bbP private groups” plugin. I’ve installed both and it’s at this time i lost my head ?

      You need to make sure that you set up the private groups correctly. Can you attach some screenshots of your private groups settings?

      Actually, even when i only install “bbPress Notify (No-Spam)”, notfication is not sent ! whereas an other plugin (“BbPress Notification”) can send notifications to admin when i activate it !!!

      I don’t understand – you said it worked fine before. Did it stop sending when you installed the private groups bridge plugin? Again, it sounds like your private groups settings aren’t correct. When you install the Private Groups bridge, bbpnns (my plugin) will only send notification to the members of the given forum. If you didn’t set up the private groups correctly, then there are no members and nobody gets notified.

      As for the other plugin, bbPress Notification, it is unrelated to my plugins.

      I’ve saw that when i uninstall all bbpress plugin (“bbPress Notify (No-Spam)” and “bbP private groups”), my preferences are still in memory – so, in base ! It’s not TOP and you’ll better include an option that will permit to delete all informations of your plugin when it will be deleted.

      Both plugins come with uninstall.php files. They only get triggered if you actually click delete to delete the plugin, per WordPress functionality. bbpnns deletes all of its options (see below), and the bridge plugin doesn’t save anything to the database at all.

      $options = array(
      		'bbpnns-dismissed-1_7_1',
      		'bbpnns-opt-out-msg',
      		'bbpress-notify-pro-dismissed',
      		'bbpress_notify_newtopic_background',
      		'bbpress_notify_newreply_background',
      		'bbpress_notify_newtopic_recipients',
      		'bbpress_notify_newreply_recipients',
      		'bbpress_notify_newtopic_email_subject',
      		'bbpress_notify_newtopic_email_body',
      		'bbpress_notify_newreply_email_subject',
      		'bbpress_notify_newreply_email_body',
      		"bbpress_notify_default_{$this->bbpress_topic_post_type}_notification",
      		"bbpress_notify_default_{$this->bbpress_reply_post_type}_notification",
      		'bbpress_notify_encode_subject',
      		'bbpnns_notify_authors_topic',
      		'bbpnns_notify_authors_reply',
      		'bbpnns_hijack_bbp_subscriptions_forum',
      		'bbpnns_hijack_bbp_subscriptions_topic',
      		'bbpress_notify_message_type',
      );
      

      Either you didn’t completely delete the bbpnns plugin, or you’re confusing the default settings with stuff stored in the database. Please elaborate on why you believe the data is being left behind, so I can check for bugs.

      What can i do ? i can let you access to my site (tell me what sort of user you want) if you want…

      You can create a temporary admin account and I’ll have a look. Please use email address vinny [at] usestrict [dot] net. Make sure you select the option to notify me of the new account.

      Cheers,
      Vinny

    • #4844
      Thierry
      Participant

      Hello vinny !

      Thanks for reply and sorry for late in “my” reply 🙁

      About uninstallation, i can’t explain why my preference stay in memory even after desactivate, delete, install and activate my plugin “bbPress Private Groups” and “bbPNNS Private Groups Bridge” : may be it’s the “bbP private groups” that do not work fine ?

      I’ve create a user at your name : you must have receive an email about this… and mine for giving your password. I’ve also send you some screen shot about my configuration…

      Thank’s a lot,

      Thierry

    • #4850
      vinny
      Keymaster

      Hi Thierry,

      Like I mentioned in my email, after adding myself to the test role and de-selecting the background mailouts, I was able to receive a message. Please check why wp-cron would not be working, and try setting up a real cron job to get the messages out.

      Cheers,
      Vinny

    • #4860
      Thierry
      Participant

      Hello Vinny,

      Thank you very much again for regarding yet my configuration…

      It was strange and i did not understand why i wasn’t work properly !
      May be this setting “background mailouts” was the reason !?

      For cron job, i’ve finish to use an external service (https://cron-job.org) because my FAI did not permit to use cron job 🙁

      Thank you again for assistance 🙂

      Thierry

    • #4861
      vinny
      Keymaster

      Hi Thierry,

      The background mailouts are working just fine in most cases. They may seem to fail (you don’t get any messages in the time expected) when there aren’t many visits to the site. That’s the downside of using wp-cron. When testing, it’s always good to remove all possible failure points, so turning that off is a good idea. You can usually even keep it off in production as long as you have a small recipient list. I’ve seen lists of 100 recipients not cause much of an impact, but 400 can cause a server time-out.

      Not allowing cronjobs seems like a petty thing to do. You should consider moving hosting company :).

      Cheers,
      Vinny

Viewing 5 reply threads
  • You must be logged in to reply to this topic.