Shop Forums WordPress Plugins Fatal error on activation

Viewing 2 reply threads
  • Author
    Posts
    • #1636
      Diego Filloy
      Guest

      Hello!

      I am having trouble activating the UPS and USPS plugin on my eShop (v6.2.16) with eShop Shipping Extension (v2.0.1).

      I uploaded the files to the wp-content/plugins as described in here http://usestrict.net/2012/07/ups-module-for-wordpress-eshop-shipping-extension/ but when I try to activate it says: “Plugin could not be activated because it triggered a fatal error.

      Fatal error: Call to undefined method USC_eShop_Shipping_Extension_UPS::set_notice() in /home/comapeno/public_html/wp-content/plugins/eshop-shipping-extension-ups/eshop-shipping-extension-ups.php on line 65”

      Thank you for the help!

    • #1637
      vinny
      Keymaster

      Hi Diego,

      set_notice() function is defined by the parent plugin eShop Shipping Extension. Do you have it installed and active? If not, you can get it from http://wordpress.org/extend/plugins/eshop-shipping-extension/. If you do have it installed, however, please make sure you have the latest version (2.0.1 at the time of writing this post) of eSE and also of UPS module (v2.0) which you can get from the download link you received by email when you purchased the module.

      Cheers,
      Vinny

    • #1641
      Diego Filloy
      Guest

      Hello Vinny,

      Apparently I had the plugin activated, so I tried disabling and enabling the eShop Shipping Extension plugin and found this error: “Failed to install module file: ups-cert.pem (copy(wp-content/plugins/eshop-shipping-extension/includes/third-party/cert/ups-cert.pem) [function.copy]: failed to open stream: Permission denied)”. So I changed the permissions on the plugin folder and everything worked.

      Thank you very much!

Viewing 2 reply threads
  • You must be logged in to reply to this topic.