Shop Forums WordPress Plugins Digest/global notifications conflicts

Viewing 10 reply threads
  • Author
    Posts
    • #5959
      Julie
      Guest

      Vinny,
      Sent this to your email but perhaps better here. Still having a problem posting to the forum when logged in – no captcha show, but get error message when trying to post (FYI).

      I have the digest and global notifications plugins.

      Situation 1
      My user has not manually subscribed to anything.

      First, I enabled “Do not notify me of global forum messages”. Working as expected, received no notifications.

      Second, I enabled forum digests and “instant” notifications. “Do not notify me of global forum messages” was still checked. Working as expected, received no notifications.

      Third, I disabled forum digests. (I did not uncheck “instant” notifications). “Do not notify me of global forum messages” was still checked. Expected to receive no notifications, however am now receiving notifications on all posts (as if “global notifications” is not recognized).

      I checked the database and “BbpnnsDigest_force_notification” entry persists. Guess somehow it is a problem with that.

      I actually did this all by accident, and hopefully is unlikely that many users would do this..but…

      Situation 2
      If the user is subscribed to 1 topic.

      First, enabled forum digests and “Do not notify me of global forum messages” was checked. Working as expected (at least for instant notifications), did not receive any notification at all.

      Second, enabled instant notifications. “Do not notify me of global forum messages” was still checked. Expected to receive only an instant notification on the post I was subscribed to, however am now receiving notifications on all posts (as if “global notifications is not recognized).

    • #5963
      vinny
      Keymaster

      Hi Julie,

      I did get your email, but unfortunately it got buried under a whole mountain of them. Sorry about that. This is indeed the best place to post support questions, as it also helps other people who are having trouble.

      What you found was a battle of the priorities, of sorts. WP works with hooks comprised of filters and actions. To decide who receives what, I use a filter to load/remove recipients.

      The option ‘Do not notify me of global forum messages’ is in fact provided by the BbpNNS Opt-Out plugin, which had a priority of 10. The instant notification option was provided by the Digests plugin, which has a priority of 1000.

      So the Opt Out removed the users and then the instant notification reloaded the ‘forcers’ back in.

      Right now I’m upping the Opt Out priority to PHP_INT_MAX so that it’s the ultimate rule into who gets removed from the recipient queue. Note, however, that core subscribers will always be added back to the notification. After all, it’s Global notifications that we block.

      I’ll release the fix to bbpNNS Opt-Out shortly.

      Cheers,
      Vinny

    • #5964
      vinny
      Keymaster

      Julie,

      Please check your WP Updates screen for Opt-Out version 1.4.1, which has that fix and also a performance improvement.

      Do let me know if you find anything else!

      Vinny

    • #5965
      Julie
      Guest

      Thanks! By “core subscribers” you mean people who have specifically subscribed to a certain topic or reply right?

      Also, I don’t see the update…still at 1.4…

    • #5968
      vinny
      Keymaster

      Yes, the people who specifically subscribed to that forum (for new topics) or topic (for new replies).

      Click ‘Check Again’ a few times to force the check. WP only checks every 12 hours by default unless you click Check Again.

    • #5969
      vinny
      Keymaster

      BTW, I deactivated the plugin that was causing the captcha issue. I’m surprised that you managed to post while logged in anyway. Thanks for bringing it up.

    • #5976
      Julia Reyes
      Participant

      Huh. Just tried now and still no update.

      I was actually logged out when I have been posting.

    • #5981
      vinny
      Keymaster

      Please create an admin account for me using email vinny [at] usestrict [dot] net so I can try to figure out why you’re not getting the updates. Basically I’m going to click the Check Again and monitor my update api logs for any hits and take it from there. Don’t post the credentials here as I’ll receive the new account notification via email anyway.

      Thanks,
      Vinny

      • This reply was modified 2 years, 3 months ago by vinny. Reason: removing the privacy setting
    • #5982
      Julia Reyes
      Participant

      Vinny,
      I’m logged in, but your last reply I still can’t see. Hmmm.

    • #5988
      vinny
      Keymaster

      I removed the privacy flag from my previous reply. You should be able to read it now.

    • #5991
      Julia Reyes
      Participant
      This reply has been marked as private.
Viewing 10 reply threads
  • You must be logged in to reply to this topic.