Shop Forums WordPress Plugins [digest-list] shortcode

Viewing 17 reply threads
  • Author
    Posts
    • #5461
      Allison Deatherage
      Participant

      I’ve been using your plugin for a few years to deliver weekly digests to our small forum. This week – the [digest-list] link didn’t work. Any idea why that might happen? I’m including the code from the email here.

      I also forget how to test this…

      And if [digest-list] won’t work – what is something else I could try. Thanks for your support Vinny!

      A

      ———————-

      Hello, [first-name]-

      This is your [frequency] notification of what’s happening in The State Recycling Leaders Forum.

      [digest-list]

      Cheers,
      Justin Gast

      Check out the the latest happenings in the forum now! click here

    • #5463
      vinny
      Keymaster

      Hi Allison,

      Thanks for reaching out. What version of the digests plugin are you using? Version 1.7 was accidentally released with a bug over the weekend and soon afterwards replaced with v1.7.1.

      Cheers,
      Vinny

    • #5491
      Allison Deatherage
      Participant

      v1.6

      Wordpress says “all plugins are up to date”. How do I force it to update?

      Thanks!
      A

    • #5492
      vinny
      Keymaster

      It should find the update automatically. Since it hasn’t, please try clicking ‘Check Again’ in the Updates screen a couple of times.

      Still, that shouldn’t cause the problem you’re seeing – my biggest concern was if you were using the bad version 1.7.

      Try to update and let me know how it goes.

    • #5493
      Allison Deatherage
      Participant

      It won’t update. Just says that everything is up to date. But it is the older version – not the buggy one.

      This is a screen shot one of my team members sent when they clicked on the link that is created with the [digest-list]. So weird…

    • #5494
      Allison Deatherage
      Participant

      I forgot the image

      Attachments:
      You must be logged in to view attached files.
    • #5496
      vinny
      Keymaster

      Please create an admin account for me so I can have a look around. Please use the following email address: vinny [at] usestrict [dot] net.

      Thanks!

    • #5497
      Allison Deatherage
      Participant

      I just added you. You should get an email…

    • #5498
      vinny
      Keymaster

      Yep, got it. I clicked the Check Again button and saw the request hit the updater server and return a valid response. I really don’t know why your WP install isn’t recognizing it.

      Can you check the file ownership and permissions for the digest in the plugins directory?

      I’ll also reset the download counter so you can manually download and re-install it just in case.

    • #5499
      Allison Deatherage
      Participant

      sorry – but where is the plugins directory?

    • #5500
      Allison Deatherage
      Participant

      It looks like you fixed it!? Did you change something? I just clicked on the link and it works, but the profile images are looking kind of funky. Maybe I can turn those off…

      Attachments:
      You must be logged in to view attached files.
    • #5502
      vinny
      Keymaster

      The plugins directory is under wp-content/ in the file system. It’s where you uploaded (if ever) the files via FTP.

      The link was likely pointing to a post that was not published yet (and you were not logged in) and then got published, or you logged in. Try hitting the link in an incognito/private window to see if it still complains that it’s not found.

    • #5503
      Allison Deatherage
      Participant

      You are amazing! Thanks Vinny!!

    • #5510
      Allison Deatherage
      Participant

      You are right. In an incognito window it still shows a page not found.

    • #5511
      Allison Deatherage
      Participant

      Going back through other digests and opening in an incognito window – I see this message.

      Could I show the name of the topic or reply that was added to the forum – but not make it an active link. And then I’ll include a link to the forum login page.

      Attachments:
      You must be logged in to view attached files.
    • #5513
      vinny
      Keymaster

      The ‘your connection is not private’ message is a bad SSL set-up.

      Can you forward me a few of the old digest messages so I can look at the generated link? I would expect the link to pass through the login window if necessary.

      Cheers,
      Vinny

    • #5521
      Allison Deatherage
      Participant

      I just emailed them to you.

      Thanks!
      A

    • #5525
      vinny
      Keymaster

      Thanks, Allison.

      The topic was definitely private at the time of mailout, as you can see the ‘Private:’ just before the subject.

      If you hover over the topic link, you’ll see it’s a huge URL, containing bbpnns-digest-login=1. That’s the part that makes you log into the site in order to see the topic.

      However, the functions I call to build the link, home_url('/') and get_permalink() are returning the httpS link, instead of http. Your Settings > General seems to be using WP_HOME and WP_SITEURL pointing to the non-SSL version of the site.

      I don’t know how it is that you set it up initially that would return the httpS link. You probably have it set that way in the database.

      So, first things first – you should get your SSL fixed, as it’s Google’s new recommendation. Depending on your host, you can get a Let’s Encrypt free certificate with a click of a button. I do that for all my sites and clients who host at Siteground (yes, it’s an affiliate link, but I stand by them).

      Second, I’d try to figure out why those functions are returning https.

      Third, I’d try to figure out why your WP is not showing the available update for the Digests plugin. I definitely see the check hitting my update server, but your install doesn’t seem to be accepting it. I know it’s not the updater class bundled with the plugin because I got the update notification on all my own installs.

      And finally, something seems to be interfering with my login redirect code. After you’re presented with the login form, it’s supposed to take you to the post you clicked on. However, there seems to be a higher priority login action that’s taking precedence. I’ll release an update with a fix for that, but then we go right back to the third item above.

      I hope this helps!

      Cheers,
      Vinny

Viewing 17 reply threads
  • You must be logged in to reply to this topic.