Shop Forums WordPress Plugins Can't save settings for digest has returned

Viewing 8 reply threads
  • Author
    Posts
    • #18653
      Jamie Furlong
      Participant

      Hi Vinny,

      Unfortunately the previous issue I had with Digest settings not saving has returned again. None of my logged in users can change their settings and BuddyPress is returning the error Your changes have not been saved. Please fill in all required fields, and save your changes again.

      Only Admin is able to save changes.

      I have updated to the latest version, deactivated and reactivated the plugin. Functions.php and bpcustom.php have not changed. I’ve tried turning caching off. All to no avail.

      Please advise.

    • #18657
      vinny
      Keymaster

      Hi Jamie,

      Please test on a staging server with a default wordpress theme and no plugins active except for bbpress, buddypress, bbpnns, and bbpnns-buddypress-bridge. I suspect either a plugin or some of your customizations are causing the issue.

      Let me know how it goes.

      Cheers,
      Vinny

    • #18659
      Jamie Furlong
      Participant

      I’ve checked the theme by switching to 2019 and the problem persists. I’m not sure how any plugin could cause the problem as none have been activated or updated recently. Also the admin is able to save the changes still, so this must be a role-based issue.

      Could you tell me what the user capability is for changing profile settings within BuddyPress is?

    • #18663
      vinny
      Keymaster

      Jamie,

      This doesn’t look like a capability issue, but some field that’s being expected in the back end. Please set up the staging server and email me the credentials and exact steps to replicate it so I can troubleshoot it for you.

      Cheers,
      Vinny

    • #18664
      Jamie Furlong
      Participant

      By staging server do you mean running a mirror website on my own machine running Wamp?

      For the record I deactivated the BuddyPress bridge plugin, reactivated it and put in the API key, and it is now working.

      Any idea why this would solve the problem?

    • #18665
      Jamie Furlong
      Participant

      Another thing we’ve noticed since reactivating the plugin: the user profile in WP admin used to contain the digest settings which admin could switch on and off. Now that I’ve reactivated the plugin the digest settings are appearing in the EXTENDED tab of the user profile.

      Where should these settings sit? The main user profile page or the extended user profile page? And why would it jump between the two upon reactivation?

    • #18718
      vinny
      Keymaster

      By staging site I mean a publicly available copy of your production site that I can access and modify to troubleshoot.

      Any idea why this would solve the problem?

      No idea without looking at your modifications.

      Once you have the staging site set up I’ll be able to look at your whole code and mods, and then we can schedule a zoom session to troubleshoot in real time. I know you’re in a very different timezone, but the way you’ve set things up with your customizations seem to be conflicting with the plugin somehow.

    • #18743
      Jamie Furlong
      Participant

      That’s going to take a while to set up and I’m not sure how I can go about that easily tbh, but in the meantime I can set you up with admin access to it live site. The users know we’re beta testing the bbpress side of things. Would that help?

    • #18956
      vinny
      Keymaster

      Let’s discuss this via email for now. I can create a staging site for you on my own servers.

Viewing 8 reply threads
  • You must be logged in to reply to this topic.